Training Analysis

by old_man_biking

Downloads: 2,939 (12) • Reviews: 3

Version:

3.0.5857

Updated:

Jan 14, 2016

NP incorrect in Critical Power tab?

NP incorrect in Critical Power tab?

Postby JanWod » Mon Apr 20, 2015 2:43 am

I have noticed that there must be some kind of error in calculation of the corresponding NP to CPn in the Critical Power tab. E.g. for a ride my CP 20 shows 303 W (i assume this is average wattage) but the NP shows only 122 W.

If i manually do the calculation for the same time interval in Excel i get the correct corresponding NP value 336 W.

080420151603.zip
Workout
(250.56 KiB) Downloaded 235 times


screendump.PNG
Screendump
screendump.PNG (133.77 KiB) Viewed 6620 times
Last edited by JanWod on Mon Apr 20, 2015 5:13 am, edited 3 times in total.
JanWod
 
Posts: 5
Joined: Wed Jul 31, 2013 4:43 am

Re: NP incorrect in Critical Power tab?

Postby tndmbkr » Mon Apr 20, 2015 3:45 am

tndmbkr
 
Posts: 233
Joined: Wed Jan 11, 2012 2:39 am
Location: Rotterdam

Re: NP incorrect in Critical Power tab?

Postby JanWod » Mon Apr 20, 2015 4:12 am

tndmbkr wrote:Did you already read this thread?
https://www.zonefivesoftware.com/sportt ... age#p85511


Yes :o
But this tread does not give any explanation to my observation. The "average power" value is correct but the "normalized power" value is not. In the calculation of the latter there should not be any doubt of the algorithm.
Last edited by JanWod on Mon Apr 20, 2015 11:30 am, edited 1 time in total.
JanWod
 
Posts: 5
Joined: Wed Jul 31, 2013 4:43 am

Re: NP incorrect in Critical Power tab?

Postby old_man_biking » Mon Apr 20, 2015 4:43 am

Pls export this ride to .fitlog format, zip and attach to your post.
I'll have a look, then
OMB
old_man_biking
Donated!
Donated!
 
Posts: 6766
Joined: Mon May 28, 2007 8:07 am
Location: Munich, Germany

Re: NP incorrect in Critical Power tab?

Postby JanWod » Mon May 18, 2015 4:10 am

Hi OMB

Did you ever look into the problem?
JanWod
 
Posts: 5
Joined: Wed Jul 31, 2013 4:43 am

Re: NP incorrect in Critical Power tab?

Postby old_man_biking » Mon May 18, 2015 7:54 am

Yes I did. Would you please read my previous post - the one just above yours :)
old_man_biking
Donated!
Donated!
 
Posts: 6766
Joined: Mon May 28, 2007 8:07 am
Location: Munich, Germany

Re: NP incorrect in Critical Power tab?

Postby JanWod » Mon May 18, 2015 8:27 am

Hm.. I did zip the .fitlog file and attached it to my initial post :?:
JanWod
 
Posts: 5
Joined: Wed Jul 31, 2013 4:43 am

Re: NP incorrect in Critical Power tab?

Postby old_man_biking » Mon May 18, 2015 9:30 am

That's where I didnt look at, I was waiting for a follow up post :)
BTW, modifying an existing post doesn't put it on the "New posts" list. So it won't get (my) attention
old_man_biking
Donated!
Donated!
 
Posts: 6766
Joined: Mon May 28, 2007 8:07 am
Location: Munich, Germany

Re: NP incorrect in Critical Power tab?

Postby old_man_biking » Mon May 18, 2015 10:49 am

Yep, you find a bug. The values for NP and EF in the table of CP... values have always been incorrect. You're the first to notice this. Congrats.

If you're interested in a beta version of the plugin, please send me a PM with your email address and a link to this post and I'll email you the beta.

Thanks,
OMB
old_man_biking
Donated!
Donated!
 
Posts: 6766
Joined: Mon May 28, 2007 8:07 am
Location: Munich, Germany


Return to Training Analysis

Who is online

Users browsing this forum: No registered users and 1 guest