Training Load

by mechgt

Downloads: 12,931 (48) • Reviews: 18

Version:

2.0.7

Updated:

Aug 26, 2015

Bug in calculation of TRIMP-Factors? - No, but possible trap

Bug in calculation of TRIMP-Factors? - No, but possible trap

Postby CStaack » Sun Oct 04, 2009 5:30 am

I made a specific Heartrate-Zone for TL. It has 20 steps:
0-126, 126-129, ..., 179-182, 182-infinity.
The TRIMP-Factors shown take a leap down in the middle instead of going up:

...
148-151: 3.9
151-154: 4.4
154-157: 2.3 :!:
157-160: 2.5
...


EDIT
More specific:
<Category name="TRIMP" referenceId="48473ce7-bd45-43c6-97e5-228756196885">
<Zones>
<Zone name="53%" low="0" high="126" />
<Zone name="55%" low="126" high="129" />
<Zone name="58%" low="129" high="132" />
<Zone name="60%" low="132" high="135" />
<Zone name="63%" low="135" high="138" />
<Zone name="65%" low="138" high="141" />
<Zone name="68%" low="141" high="144" />
<Zone name="70%" low="144" high="148" />
<Zone name="73%" low="148" high="151" />
<Zone name="75%" low="151" high="154" />
<Zone name="78%" low="154" high="157" />
<Zone name="80%" low="157" high="160" />
<Zone name="83%" low="160" high="163" />
<Zone name="85%" low="163" high="166" />
<Zone name="88%" low="166" high="169" />
<Zone name="90%" low="169" high="173" />
<Zone name="93%" low="173" high="176" />
<Zone name="95%" low="176" high="179" />
<Zone name="98%" low="179" high="182" />
<Zone name="100%" low="182" />
</Zones>
</Category>

Thanks for caring,
Christian.
Last edited by CStaack on Wed Oct 07, 2009 12:14 pm, edited 1 time in total.
CStaack
Donated!
Donated!
 
Posts: 17
Joined: Sun Oct 04, 2009 5:15 am
Location: Kiel, Germany

Postby Stumpjumper68 » Sun Oct 04, 2009 4:36 pm

You need to enter the factors by yourself.
I guess you missed it during splitting such a lot of zones. :)
Image
Stumpjumper68
Donated!
Donated!
 
Posts: 1074
Joined: Thu Oct 11, 2007 3:39 pm
Location: Bad Vilbel, Germany

Postby mechgt » Sun Oct 04, 2009 8:30 pm

Thanks for posting your categories like that, it made it super easy to test.

So I copied your category directly into my logbook (to test it), but the factors appear to have been calculated correctly for me (see screenshot below). I wonder if you created this HR category, TL calculated factors for it, then you maybe modified it (added more zones for instance) and that's where the weird break came from. Anyhow, there's a 'Reset Category' button that should redo the automatic calculations for you. You may have to click around and select different categories or something as it looks like this button is hidden sometimes.

Try the 'Reset' button and let me know if you still have issues with it.

Image
Enhance SportTracks with Training Load, Fit Plan and more plugins at mechgt.com. Garmin FR310XT & iBike iPro
mechgt
Donated!
Donated!
 
Posts: 1188
Joined: Wed Sep 26, 2007 2:13 pm
Location: Atlanta, GA, USA

Postby CStaack » Mon Oct 05, 2009 12:43 pm

mechgt wrote:I wonder if you created this HR category, TL calculated factors for it, then you maybe modified it (added more zones for instance) and that's where the weird break came from.


You're perfectly right. That's exactly what happened. The curve looks fine now.

Thank you very much!
CStaack
Donated!
Donated!
 
Posts: 17
Joined: Sun Oct 04, 2009 5:15 am
Location: Kiel, Germany

Postby mechgt » Mon Oct 05, 2009 12:46 pm

Awesome, glad I could help.
Enhance SportTracks with Training Load, Fit Plan and more plugins at mechgt.com. Garmin FR310XT & iBike iPro
mechgt
Donated!
Donated!
 
Posts: 1188
Joined: Wed Sep 26, 2007 2:13 pm
Location: Atlanta, GA, USA


Return to Training Load

Who is online

Users browsing this forum: No registered users and 2 guests