Page 1 of 1

Average Power discrepancy

PostPosted: Mon Jul 27, 2015 5:46 am
by FranR
Hi OMB,

I am noticing a discrepancy in AP figures in the Critical power tab.

As you can see in the attached image, CP20 for this ride is 228W, while the average power for this segment in the graph above shows an average of 233,7W.

cp.JPG
cp.JPG (186.74 KiB) Viewed 4160 times


Since the graph value is higher, my initial assumption was that maybe calculation of figures in the graph are done using the Standard ST AP calculation, not including zero values... but I am finding other instances where graph averages are lower than corresponding CP values, which kind of ruins my theory (see second screen grab).

cp2.JPG
cp2.JPG (81.78 KiB) Viewed 4160 times


Can this possibly be a bug, or is there an explanation I am missing?

Re: Average Power discrepancy

PostPosted: Sat Aug 08, 2015 2:05 am
by pkiszk
A somewhat related question - is it possible to modify the average power for a selected section of the graph to normalised power ? Ie, when I do an interval during workout and want to compare its NP with another interval from a different day but for the same duration I can only check average power but not NP. Or is there another way to look for NP data for selected sections of the graph/workout ?

regards,
Przemek

Re: Average Power discrepancy

PostPosted: Sat Aug 08, 2015 9:32 am
by tndmbkr
The calculation of an average value by ST3core is affected by the chosen smoothing factor.
Calculations in TA are not affected by smoothing.
In TA the smoothing only helps you to achieve a nice looking chart.

PS; Is this question related to this post?
viewtopic.php?f=24&t=16803