After Import

by old_man_biking

Downloads: 2,020 (13) • Reviews: 0

Version:

3.0.5720

Updated:

Aug 30, 2015

Error: The remote server returned an error: (400) Bad Reques

Error: The remote server returned an error: (400) Bad Reques

Postby WillRunForBeer » Wed Oct 04, 2017 8:49 am

I am getting a popup with "Error: The remote server returned an error: (400) Bad Request" the first time I run after import processing, after starting sporttracks. If I x out of the popup and run it again the error does not appear.

This behavior has been for about two weeks.

My after import plugin automation is configured to 1. add equipment items according to their "Import settings", and, 2. find weather information [through weather plugin]

Versions:
    Sporttracks 3.1.6179
    After Import Plugin 3.0.5720
    Weather Plugin 3.0.5966

Weather provider - Sport Tracks World Weather
WillRunForBeer
Donated!
Donated!
 
Posts: 35
Joined: Wed Mar 08, 2006 4:29 am

Re: Error: The remote server returned an error: (400) Bad Re

Postby old_man_biking » Wed Oct 04, 2017 2:32 pm

WillRunForBeer wrote:I am getting a popup with "Error: The remote server returned an error: (400) Bad Request" the first time I run after import processing, after starting sporttracks. If I x out of the popup and run it again the error does not appear.

This behavior has been for about two weeks.

My after import plugin automation is configured to 1. add equipment items according to their "Import settings", and, 2. find weather information [through weather plugin]

Versions:
    Sporttracks 3.1.6179
    After Import Plugin 3.0.5720
    Weather Plugin 3.0.5966

Weather provider - Sport Tracks World Weather

I'm not sure why/how this relates to After Import plugin.
There have been a few posts recently referring to problems with Weather plugins reading data from airport ("ICAO") stations. Maybe it's this.
To verify this, disable automatic weather import in AI plugin, or disable you Airport weather stations or disable Weather plugin in general.
If this solves your issue, it's related to the Weather plugin issue.
Cheers,
OMB
User avatar
old_man_biking
Donated!
Donated!
 
Posts: 6731
Joined: Mon May 28, 2007 8:07 am
Location: Munich, Germany

Re: Error: The remote server returned an error: (400) Bad Re

Postby WillRunForBeer » Sat Oct 07, 2017 8:14 am

I was reporting based on symptom, but it does make sense this is more related to the weather plugin. Interesting that the error doesn't occur on the second attempt to retrieve the weather data, though.

I'm on travel now and will be for a couple of weeks. The error did not occur this morning, which is consistent with the thought that this is a station type related error -- or at least that it is related to some stations near my home.

I'll bring this discussion to the weather plugin forum and try to debug more when I get back home.

Thanks as always for your great plugins.
WillRunForBeer
Donated!
Donated!
 
Posts: 35
Joined: Wed Mar 08, 2006 4:29 am

Re: Error: The remote server returned an error: (400) Bad Re

Postby robert.ellershaw@bigpond. » Wed Dec 06, 2017 7:51 pm

Hi OMB

I have also been getting the error message ""Error: The remote server returned an error: (400) Bad Request" for a few weeks now.
My location is Townsville, QLD Australia. It is definitely related to the OMB weather plugin as only occurs when I update the weather.

System info
WIN 10 os
SportTracks ver 3.1.6179
Weather plugin Version: 3.0.5966 (Build 3.0.5966.13926, 2/05/2016 7:44 AM)

Have you managed to fix the problem yet?

Best regards
Robert Ellershaw
robert.ellershaw@bigpond.
 
Posts: 3
Joined: Sat Oct 09, 2010 8:44 pm
Location: Townsville QLD

Re: Error: The remote server returned an error: (400) Bad Re

Postby old_man_biking » Thu Dec 07, 2017 3:11 am

Hi Robert,

see viewtopic.php?f=78&t=17857#p92577 .

Cheers,
OMB
User avatar
old_man_biking
Donated!
Donated!
 
Posts: 6731
Joined: Mon May 28, 2007 8:07 am
Location: Munich, Germany

Re: Error: The remote server returned an error: (400) Bad Re

Postby robert.ellershaw@bigpond. » Fri Dec 08, 2017 9:11 pm

Hi OMB

Thank you for your response I read your link & your response.

After yet another look: no chance to work around Wunderground.com's drop of ICAO support. So ICAO stations won't work any longer within Weather plugin.
Sorry,
OMB

Does this mean the end of the weather plugin working or can I simply delete the ICAO stations? What is your best advice please?

Thank you for your help & support.

Best regards
Robert Ellershaw
robert.ellershaw@bigpond.
 
Posts: 3
Joined: Sat Oct 09, 2010 8:44 pm
Location: Townsville QLD

Re: Error: The remote server returned an error: (400) Bad Re

Postby old_man_biking » Sat Dec 09, 2017 2:33 am

Only ICAO (airport) stations are affected, the vast majority of stations work well. So delete the ICAO stations.
OMB
User avatar
old_man_biking
Donated!
Donated!
 
Posts: 6731
Joined: Mon May 28, 2007 8:07 am
Location: Munich, Germany

Re: Error: The remote server returned an error: (400) Bad Re

Postby robert.ellershaw@bigpond. » Sat Dec 09, 2017 7:16 pm

Hi OMB
Many thanks
Best regards
Robert Ellershaw
robert.ellershaw@bigpond.
 
Posts: 3
Joined: Sat Oct 09, 2010 8:44 pm
Location: Townsville QLD


Return to After Import

Who is online

Users browsing this forum: No registered users and 1 guest