Sub catagories not saving/changing

Post a question about the software or find answers here.

Sub catagories not saving/changing

Postby afv1980 » Sun Feb 10, 2019 5:57 pm

After a sync between Sporttrack and ST3 my subcatagories are not being saving. I.e, running:treadmill changes to running and then back to generic "my activities" in ST3. I have associated all the proper icons in ST3 cloud syncing, but did not change outcome. It only seems to occur with recent activities after Jan 31, 2019. Older activities seem OK.

Jeff
afv1980
 
Posts: 13
Joined: Tue Feb 22, 2011 8:36 pm

Re: Sub catagories not saving/changing

Postby staffann » Tue Feb 12, 2019 1:37 pm

You have to define one (sub)category in ST for each (sub)activity-type that you use in mobi and define the mapping between them. I.e. you need to have one-to-one relationship. Otherwise the sync process will do that you describe. It is a major nuisance that I was recently in contact with the support about. Basically if you use all of the activity types in mobi, you will have to manually create maaaaany (sub)categories in ST3 and map them.
On the ST2Funbeat development team. Author of the Svettig (jogg.se) and Compare Planned plugins.
staffann
Donated!
Donated!
 
Posts: 355
Joined: Mon Dec 28, 2009 4:33 pm
Location: Sweden

Re: Sub catagories not saving/changing

Postby afv1980 » Tue Feb 12, 2019 6:45 pm

Thank you for the response. The problem seems to be corrected using this procedure. It didn't seem to work at first which is why I posted, but now it seems to work. It also seemed to be a recent occurrence which also was puzzling to me.
afv1980
 
Posts: 13
Joined: Tue Feb 22, 2011 8:36 pm

Re: Sub catagories not saving/changing

Postby SzDoc » Sun May 26, 2019 12:28 pm

Given the impending demise of ST3, I'm figuring out how to move my 10 years of highly curated date to Mobi.

So, do the subcategories sync the other way, e.g. ST to Mobi? Or, do I have to define the categories in Mobi first?

Thanks much.
SzDoc
 
Posts: 14
Joined: Fri Sep 03, 2010 3:10 pm

Re: Sub catagories not saving/changing

Postby admin » Tue May 28, 2019 11:51 am

Unlike ST3, the SportTracks online platform doesn't have the concept of custom user defined categories. Instead you can pick from a hundred or so predefined sport > sub-sport icons for a workout. When you set up the ST3 Cloud Sync feature you need to associate your custom categories with the correct sport icons so it knows how to map the data over.
Get the latest info: Fan us on facebook or follow us on twitter
admin
Site Admin
Site Admin
 
Posts: 3003
Joined: Tue Apr 05, 2005 8:52 pm
Location: USA

Re: Sub catagories not saving/changing

Postby SzDoc » Wed May 29, 2019 9:29 am

Got it. Have to map all of my custom sub-cats to existing Mobi cats.
What about custom data fields?
SzDoc
 
Posts: 14
Joined: Fri Sep 03, 2010 3:10 pm

Re: Sub catagories not saving/changing

Postby admin » Thu Jun 06, 2019 7:46 am

SzDoc wrote:What about custom data fields?

Custom data fields will not transfer from your ST3 logbook to the SportTracks online account using Cloud Sync.
Get the latest info: Fan us on facebook or follow us on twitter
admin
Site Admin
Site Admin
 
Posts: 3003
Joined: Tue Apr 05, 2005 8:52 pm
Location: USA

Re: Sub catagories not saving/changing

Postby cbenson33 » Tue Jul 23, 2019 9:50 am

admin wrote:
SzDoc wrote:What about custom data fields?

Custom data fields will not transfer from your ST3 logbook to the SportTracks online account using Cloud Sync.


So is there a way to export those custom data fields say to a csv file??
cbenson33
Donated!
Donated!
 
Posts: 33
Joined: Fri Jul 31, 2009 11:20 am
Location: Rochester, NH

Re: Sub catagories not saving/changing

Postby Tisztul_A_Visztula » Wed Jul 31, 2019 5:25 pm

Yes, it is. As I remember the core ST3 is not able to do that, but either Copy data plugin (if this one exists at all) or Custom Data Tracks plugin provides it. See export/custom data fields or similar
Cheers,
Zoltan
Tisztul_A_Visztula
 
Posts: 525
Joined: Thu Jul 15, 2010 8:38 am
Location: Hungary

Re: Sub catagories not saving/changing

Postby pucko » Sat Aug 31, 2019 2:38 pm

My category sync is totally messed up.

I have the structure:

My activities
- Training
--- Running
-----Trail
-----Treadmill

Mapped correctly, If I change an activity category in ST3, it gets correctly synced to Mobi, but not the other way. So when
an activity is created in Mobi from Garmin correct, and then gets over to ST3 it is alwasy flagged as "My activities" not the correct sport eaven thoug it is correct
in Mobi. If I start from a clean logbock in ST3 it get eaven worse, it syncs back the wrong category and wipe it out in Mobi.
pucko
 
Posts: 10
Joined: Sun Jul 03, 2011 9:46 am

Re: Sub catagories not saving/changing

Postby staffann » Fri Sep 06, 2019 11:20 am

pucko wrote:Mapped correctly


Have you mapped them one-to-one, i.e. each ST3 category mapped to a separate mobi category and each mobi category mapped to a separate ST3 category?
On the ST2Funbeat development team. Author of the Svettig (jogg.se) and Compare Planned plugins.
staffann
Donated!
Donated!
 
Posts: 355
Joined: Mon Dec 28, 2009 4:33 pm
Location: Sweden

Re: Sub catagories not saving/changing

Postby geminiboy » Fri Sep 13, 2019 10:33 am

pucko wrote:My category sync is totally messed up.

I have the structure:

My activities
- Training
--- Running
-----Trail
-----Treadmill

Mapped correctly, If I change an activity category in ST3, it gets correctly synced to Mobi, but not the other way. So when
an activity is created in Mobi from Garmin correct, and then gets over to ST3 it is alwasy flagged as "My activities" not the correct sport eaven thoug it is correct
in Mobi. If I start from a clean logbock in ST3 it get eaven worse, it syncs back the wrong category and wipe it out in Mobi.



same problem for me, activities are flagged as"My activities" and the real activity goes on "Name"..

send a mail to spottrack to help me... i wait the asnswer...
geminiboy
 
Posts: 2
Joined: Mon Jan 14, 2013 1:15 pm

Re: Sub catagories not saving/changing

Postby admin » Wed Sep 18, 2019 10:15 am

the poster above worked this through with support and it turned out to be an error on the user's system configuration, possibly related to plugins.
Get the latest info: Fan us on facebook or follow us on twitter
admin
Site Admin
Site Admin
 
Posts: 3003
Joined: Tue Apr 05, 2005 8:52 pm
Location: USA


Return to Questions

Who is online

Users browsing this forum: No registered users and 1 guest

cron