Page 1 of 1

Unable to load logbook

PostPosted: Sun Jul 22, 2018 12:04 pm
by zacklaws
After years of hardly no issues, I have now hit one that I cannot resolve, I'm unable to load my logbook, usually I can resolve this problem, and I have had similar and maybe even this one before, but this time, I cannot. The error message I am getting is:-

Exception of type 'System.OutOfMemoryException' was thrown.

at System.Array.Resize[T](T[]& array, Int32 newSize)
at ZoneFiveSoftware.Common.Data.TimeDataSeriesBase`1.set_Capacity(Int32 value)
at ZoneFiveSoftware.SportTracks.Data.Activity.ReadXml(XmlDocument xmlDoc, XmlNamespaceManager nsmgr, XmlElement node)
at ZoneFiveSoftware.SportTracks.Data.Logbook.ReadXml(XmlDocument xmlDoc, XmlNamespaceManager nsmgr, XmlElement node)
at ZoneFiveSoftware.SportTracks.IO.LogbookIO.Open(String filename, IJobMonitor monitor, JobResults& results)

Any help will be more than appreciated.

Problem sorted, after trying a few logbook backups and non of them worked, I retried the backup plugin for a couple of times and it eventually worked.

Re: Unable to load logbook

PostPosted: Mon Jul 23, 2018 6:19 am
by gerhard
It seems like you have hit the maximum logbook size limit.
Starting with maps None may help temporarily.

Keep a copy of the logbook that opens, then purge activities (like before a certain year, My Friends etc).

Re: Unable to load logbook

PostPosted: Mon Jul 23, 2018 8:28 am
by texmurphy
Use Admin's Plugin Compress Data: ... press-data

Open ST3 without a logbook to set Maps=NONE, then close ST3.

Re: Unable to load logbook

PostPosted: Tue Aug 28, 2018 3:22 pm
by pkiszk
The compress plugin doesn't load in my case - any idea's why ? I have the message that it has been installed but nothing shows under Plugin section after opening the database (if I manage to open it, size is 317MB and I can open it only if I kill a number of apps via the windows Task Manager).

Also - as far as equipment usage is concerned - can it be maintained 'en masse' or do I have to manually copy historic usage for years that I have to delete to reduce database size ?

And - what will happen to my activities for activities manually removed from ST3 database on my PC ?


Re: Unable to load logbook

PostPosted: Tue Aug 28, 2018 4:12 pm
by admin
Try download the compress plugin again it looks like there was a bad image on the download website.

If you delete database in ST3 all those changes are synchronized to the online SportTracks account when CloudSync is enabled and activated. Sync is bi-directional. Changes in ST3 go to SportTracks online, Change in SportTracks online go to ST3, so it's the same workout history everywhere. The system will keep them in sync always when it is enabled.

Probably if you run out of room for history in ST3 and also use SportTracks online with CloudSync, it is better to discontinue the ST3 use, rather than delete your history. You can disable the sync, but I think it becomes a pain to maintain two separate different copies and manage all the data sync manually.

Re: Unable to load logbook

PostPosted: Tue Aug 28, 2018 7:08 pm
by texmurphy
@pkiszk I suggest you review this forum entry for nuggets of information/ensight: viewtopic.php?f=11&t=11001

With a large (full-ish) logbook, it can be difficult to compress the logbook at first. You need memory to free memory. So be sure to set Maps=NONE and unload plugins you don't need for the process. Always start with a fresh ST3 load. Begin your compress on a few activities at a time (week or month), selecting on the Daily Activity top window and then doing Edit->Compress Data. After doing some weeks/months, do a Logbook->Save, close ST3, and then start a fresh load of ST3.
This also holds true if you elect to delete activities from a fool-ish logbook. If you delete, then be sure to untick the Mobi Synch plugin to keep your Mobi activities.
Before doing any deletes, especially if you are splitting logbooks, copy all the usage time/distance on your equipment. After doing activity deletes, you can go back and add the time/distance to your active Equipment items.

Re: Unable to load logbook

PostPosted: Wed Sep 05, 2018 10:07 am
by pkiszk
Thank you for feedback. I can report that I managed to shrink the database to some 273MB and it now opens on my two computers. I exported old 2009-2012 workouts and shrank the rest - doing it in huge batches - full years at a shot - worked fine. It did not reduce the database size by much (a few megabytes). In any case, it seems to work now.