Pool Swimming

by old_man_biking

Downloads: 1,404 (11) • Reviews: 8

Version:

3.0.5913

Updated:

Mar 10, 2016

Odd bug in lap time calculation

Odd bug in lap time calculation

Postby tla » Sat Jun 01, 2013 7:58 am

Hello, I imported a swimming FIT file today and I see something very strange in lap 4 in the attached screenshot.
st_pool_plugin_bug.tiff
st_pool_plugin_bug.tiff (55.92 KiB) Viewed 4281 times

It appears to start at 10:06:01, and the following rest interval at 10:07:26, but the elapsed time is 13 seconds. (I assure you I did not do 50 meters of breaststroke in 13 seconds, and 1:25 is much more likely.) Any ideas what is causing this? I did some editing of the other laps but not this one, and the bug was there before I edited (and after I deleted and re-imported the activity.)
tla
 
Posts: 2
Joined: Sat Jun 01, 2013 7:51 am

Re: Odd bug in lap time calculation

Postby old_man_biking » Sat Jun 01, 2013 3:57 pm

tla wrote:Hello, I imported a swimming FIT file today and I see something very strange in lap 4 in the attached screenshot.
st_pool_plugin_bug.tiff

It appears to start at 10:06:01, and the following rest interval at 10:07:26, but the elapsed time is 13 seconds. (I assure you I did not do 50 meters of breaststroke in 13 seconds, and 1:25 is much more likely.) Any ideas what is causing this? I did some editing of the other laps but not this one, and the bug was there before I edited (and after I deleted and re-imported the activity.)

There's more than a fair chance that your Garmin device has erroneously recorded it like this. The devices are far from being perfect.
Did you try to upload the .FIT file to Garmin Connect and check the data there? If not, please try that first.
If yes, and the data look ok in GC, zip and attach your .FIT file to your post and tell us if you used ST's standard importer or Garmin FIT Devices plugin for import.

Cheers,
OMB
old_man_biking
Donated!
Donated!
 
Posts: 6513
Joined: Mon May 28, 2007 8:07 am
Location: Munich, Germany

Re: Odd bug in lap time calculation

Postby tla » Sun Jun 02, 2013 3:06 pm

Okay you're right, something is garbled in the FIT file. It reports the lap overview as 2 lengths, total 50 meters (in a 50m pool no less), total time 1:25.3, length 1 in :13.1 and length 2 doesn't exist. How odd.
tla
 
Posts: 2
Joined: Sat Jun 01, 2013 7:51 am


Return to Pool Swimming

Who is online

Users browsing this forum: No registered users and 1 guest

cron